【www.5929.com】什么样在CMD里面查看端口是不是可用以及查询端口是或不是被占用状态,课程内容小说

第一步:
dubbo-monitor-simple-二.5.叁连上zookeeper注册中央,获得要调用的接口的ip和端口号

在win七上丰裕服务:

视图模式介绍:
用户格局 router>
特权格局 router#
大局形式 router(config)#
接口形式 router(config-if)#

希图工作:

首先,要认同telnet命令是不是可用,如图:

www.5929.com 1

图 一 telnet命令不可用

www.5929.com 2

图 二 命令可用,不过端口未开启

倘诺命令不可用,则参照他事他说加以考查:telnet客户端安装(1、二、三、四)

要是命令可用,则参照他事他说加以考察:telnet客户端安装(5、六、7)

第二步:
输入指令:telnet 1玖二.16捌.x.xxx xxxxx

操作进程:点击”初步”→”调整器面板”→” 查看格局:类型”则点击”程序”(”查看情势:大Logo”则点击”程序和效劳”)→ “运行或关闭windows功用”→ 在”Windows功效”分界面勾选Telnet服务器和客户端 →最后点击”明显”等待安装。

用->特 :enable/en
特->全:config t
全->接口:int 接口名称 举个例子int s0/0/0或int f0/0
路由共商视图router(config-route)# /在大局形式下输入router
动态路由和睦名称

telnet客户端安装与利用:

一、展开调整面板点击程序

www.5929.com 3

图 三 调节面板

2、点击启动或关闭windows效用

www.5929.com 4

图 四 运行或关闭Windows效用

三、选取Telnet客户端点击明确

www.5929.com 5

图 5 选择Telnet客户端

4、安装到位

www.5929.com 6

图 陆 安装到位

五、windows键+R打开CMD

www.5929.com 7

图 7 打开CMD

陆、输入指令,格式:telnet IP 端口号,举个例子:telnet www.sina.com 80

www.5929.com 8

图 8 输入指令

七、命令输入完结后点击enter键盘,假设没错则如下图

www.5929.com 9

图 9 telnet命令正确

回车的后边一旦展现 :Escape character is ‘^]’.

使用telnet:

壹、一般的常用命令
router(config-if)#exit
router(config)#
router(config-router)#exit
router(config)#
router(config-line)#exit
router(config)#
router(config)#exit
router#
exit命令/从接口、协议、line等视图情势下退回到全局配置格局,或从全局配置形式退回到特权形式

询问端口是还是不是被占用:

一、打开CMD

www.5929.com 10

图10 打开CMD

2、输入指令netstat -ano

www.5929.com 11

【www.5929.com】什么样在CMD里面查看端口是不是可用以及查询端口是或不是被占用状态,课程内容小说。图 11 端口状态

LISTENING:表示IP和端口处于监听状态,等待客户端连接

ESTABLISHED:表示组建了连年

代表连接成功,正在监听dubbo服务

开发cmd窗口,输入telnet ip port 查看该服务器和端口是不是连接上

【www.5929.com】什么样在CMD里面查看端口是不是可用以及查询端口是或不是被占用状态,课程内容小说。router(config-if)#end
router(config-router)#end
router(config-line)#end
router#
end命令/从其余视图直接回到特权情势

总结:

上述就是服务器陈设时测试端口服务和询问端口服务是或不是开启时的下令,假如有其余题目,迎接一齐谈谈

第三步:

有关命令总括:

router#Logout /退出当前路由器登入情势绝对与windows的撤销
router#reload
/重新开动路由器(热运维)冷运转正是关闭路由器再张开电源开关

输入:ls

ping + ip: 查看某3个ip地址是不是能够联网,如: ping 1⑨二.16捌.0.一5三

二、路由基本设置

能够呈现该ip端口下的享有服务名称

telnet ip port : 查看某二个机械上的某二个端口是或不是能够访问,如:telnet
1玖2.16八.0.1伍三 1334

router>enable /进入特权方式
router#conf t /进入全局配置方式
router(config)# hostname xxx /设置设备名称

第四步:

剥离命令:

(1)设置口令
router(config)#enable password password /使能口令
router(config)#enable secret password /使能加密口令

输入:invoke xxx.services.facade.xxx.xxxFacade.getUserById(123)

ctrl+],之后在按q —退出telnet分界面

(二)设置telnet服务情势
router(config)#line vty 0 四 /进入安装telnet服务情势
router(config-line)#password xxx /设置telnet的密码
router(config-line)#login /使能得以登入

 

exit—退出dos窗口

(三)调节台线路安装
router(config)#line con 0 /进入调控口的劳务形式
router(config-line)#password xxx /要设置console的密码
router(config-line)#login /使能得以登入

留意:假如遇上提醒 telnet不是里面命令,请遵照如下操作:
1.开采调控面板,

q!,wq—Linux下退出vi编辑器

(四)接口配置
router(config)#www.5929.com,int s0/0/0 /进入接口配置形式
router(config-if)#ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
/增加ip 地址和掩码给环回口 在情理接口上配备了ip地址后用no
shut启用那一个概略接口反之能够用shutdown 处理性的关门接口
router(config-if)#no shut
router(config-if)#login

二.点击 程序和效劳,

quit—退出mysql…….

(五)DCE接口始终频率设置
router(config)#int s0/0/0
router(config-if)#clock rate 64000
router(config-if)#no shut
Ctrl+z

叁.点击 张开或关闭windows功用,

router(config-if)#enca hdlc/ppp
/捆绑链路协议hdlc 也许ppp Cisco缺省串口封装的链路层协议是HDLC所以在show
run配置的时候接口上的陈设未有,若是要卷入为其余链路层协议
比如PPP/FLAND/X二伍正是见到接口下的enca ppp可能enca fr
router(config)#int loopback
/创设环回口(逻辑接口)模拟差别的本机网段

4.将 Telnet客户端,勾选上。

三、路由安插:
(1)静态路由
router(config)#ip route xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
下一条或本人的接口
router(config)#ip route 0.0.0.0 0.0.0.0 s 0 增加缺省路由

(贰)动态路由
rip协议
router(config)#router rip /启动rip协议
router(config-router)#network xxx.xxx.xxx.xxx /公布本人的网段
router(config-router)#version 2 转换为rip 2版本
router(config-router)#no auto-summary /关闭自动汇总作用,rip
V贰才有意义
router(config-router)# passive-int
接口名/运行本路由器的不行接口为被动接口
router(config-router)# nei xxx.xxx.xxx.xxx
/广播转单播报文,钦点邻居的接ip,

igrp协议—–内部网关路由协调(IGRP:Interior Gateway Routing
Protocol)
router(config)#router igrp xxx /启动igrp协议
router(config-router)#network xxx.xxx.xxx.xxx /公布本身的网段
router(config-router)#variance xxx
/调治倍数因子,使用不等价的载荷均衡
eigrp—Enhanced Interior Gateway Routing
Protocol(巩固网关内部路由线路协议)
router(config)#router eigrp xxx /运维商业事务
router(config-router)#network xxx.xxx.xxx.xxx /公布自个儿的网段
router(config-router)#variance xxx
/调解倍数因子,使用不等价的负荷均衡
router(config-router)#no auto-summary /关闭自动汇总成效

ospf和睦—-开放最短路线协议(OSPF)协议
router(config)#router ospf xxx /运行商业事务运营3个OSPF协议进程
router(config-router)#network xxx.xxx.xxx.xxx area xxx
/公布自身的接口或网段在ospf的区域中,能够把差别接口发表在差异区域中
router(config-router)#router-id xxx.xxx.xxx.xxx /配置路由的id
router(config-router)#area xxx stub
/配置xxx区域为末梢区域,参与这些区域的路由器全体要布局那个条命令
router(config-router)#area xxx stub no-summary
/配置xxx区域为完全末梢区域 只在AB凯雷德上安排
router(config-router)#area xxx nssa
/配置xxx区域为非纯末梢区域,参预这一个区域的路由器全体要布署那一个条命令
router(config-router)#area xxx nssa no-summary
/配置xxx区域为完全非纯末梢区域,只在AB瑞鹰上配备,并公布缺省路由音信进入那一个区域内的路由器

四、保存当前修改/运行的布局:
router#write
/将RAM中的当前安插存款和储蓄到NVRAM中,下一次路由器运营正是奉行保存的布置
router#Copy running-config startup-config /命令与write效果同样

特权情势下

翻看命令
router#show running-config /查看当前运作配置
router#show startup-config /查看运营配置
router#show ip route /查看当前的路由表
router#show ip int brief /查看当前的路由器的接口ip地址启用情况
router#Show interfaces
/展现设置在路由器和做客服务器上具备接口的计算音信展现路由器上配置的保有接口的图景
router#Show interfaces serial /突显关于2个串口的新闻
router#Show ip interface
/列出三个接口的IP新闻和情况,列出接口的状态和全局参数

router#debug ip pack /展开ip报文的调试
router#terminal monitor /输出到终点上显得调节和测试音信

翻看协议
router#show ip protocol /查看当前路由器运维的动态路由和睦情状
router#show ip eigrp neighbors /查看eigrp协议的邻居表
router#show ip eigrp top //查看eigrp协议的拓朴表
router#show ip eigrp interface /查看当前路由器运维eigrp协议的接口情况
router#show ip ospf neighbor /查看当前路由器的ospf协议的邻居表
router#show ip ospf interface /查看当前路由器运维ospf协议的接口情形

清除
router#clear ip ospf process /清除当前路由器ospf协议的长河
router#clear ip route * /清除当前的路由表

Leave a Comment.